Home » Applications » PeopleSoft, JD Edwards & Siebel » Insert fails into AS400 from 10g using otgwyDRDA (tgwy drda, 10g2 as400 jde)
Insert fails into AS400 from 10g using otgwyDRDA [message #333357] Fri, 11 July 2008 06:44
Messages: 4
Registered: June 2008
Location: NYC
Junior Member
I'm experiencing what I preceive as odd behavior when I try to insert into an AS400 from Oracle 10g2 using the OTGWY DRDA.

First, I was able to install and configure correctly. SELECT statements executed efficiently. I even created a table on AS400, journall edit, was able to insert and delete. Further along in our ETL development, one of our requirements was to dump data into some AS400 tables. We verified that they were in fact getting journalled and I ran a test insert statement and it executed correctly and I was able to delete the row as well and commit. Here is that statement:" insert into f4715_jde values('8',1,'00010',100054,'CE',1000,' ',' ','F47012' ,' ',0,' ',0,' ',100,'AF','MODEL N',' ',' ',' ',108191,134148);" Please note that f4715 is a public synonym to the AS400 table I am trying to insert into. Then, I placed a similiar statements in a PL/SQL block and they failed. here are those statements: "INSERT INTO F4715_JDE (ZDEDTY,ZDEDSQ,ZDEKCO,ZDEDOC,ZDEDCT
FROM F4715_ETL;"

FROM F4715_ETL); "

Pleas note that F4715_ETL is the Oracle table and F4715_JDE is the synonym that points to the AS400 table. here is the error message I get:
ERROR at line 1:
ORA-28500: connection from ORACLE to a non-Oracle system returned this message:
TG4DRDA v10. grc=0, drc=-777 (839C,0000), errp=QSQPLIST
sqlcode=-5001, sqlstate=42703, errd=0,0,0,0,103,0
ORA-02063: preceding 4 lines from JDE

Finally, I ran the COPY FROM statement and it inserted fine, but I can't use a SQLPLUS Command in PL/SQL.
stgdev:etladmin> copy from etladmin/etl123@stgdev.parpharm.com -
> insert testdta.f4715@jdedev -
> using select * FROM F4715_ETL;

Array fetch/bind size is 4000. (arraysize is 4000)
Will commit when done. (copycommit is 0)
Maximum long size is 80. (long is 80)
1 rows selected from etladmin@stgdev.parpharm.com.
1 rows inserted into TESTDTA.F4715@JDEDEV.
1 rows committed into TESTDTA.F4715@JDEDEV at DEFAULT HOST connection.

stgdev:etladmin> commit;

Does anyone have any thoughts on what I am missing here????

Thank you in advance for any help that is offered.

Previous Topic: PeopleSoft DBA Forum Running the java APIs for Component Interfaces
Next Topic: Siebel 8.0 memory tunables for Unix?
Goto Forum:

Current Time: Tue Jun 06 11:37:16 CDT 2023