Home » Non-English Forums » Japanese » SQL*plus behaviour with Japanese data
SQL*plus behaviour with Japanese data [message #7324] Wed, 04 June 2003 13:12 Go to next message
Messages: 1
Registered: June 2003
Junior Member
This is a typical problem I have found with the SQL*plus tool. When I am trying to insert Japanese characters into database using an insert script, rows are getting inserted but when we try to retrieve, it is showing JUNK data. My database server and client both are of 8.1.7 version and UTF8 Charset based. NLS_LANG has been set to japanese_japan.ja16sjis.

To explain clearly, I am saving insert commands script as file1.sql with 'save as type' UTF8 in notepad, with font 'tahoma'. Then I am able to see Japanese chars in script file. When I run this script from SQL*plus as @file1.sql, rows were inserted. I have a JSP file to see the output of query, through browser. When I quried this table, browser is showing some Junk chars (but looks like Japanese, not exactly). Funnily, when I copy an insert statement alone from script and paste it in SQL*plus window, it is showing evrything correctly except the values in japanese values column. instead it shows ? symbols. I have tried this with other languages like chinese, polish etc. then it worked fine. Do i need apply any fix pack to SQL*plus? or do i need any other settings to do on client m/c side? A quick response is really helpful.

Thanks in advance
Re: SQL*plus behaviour with Japanese data [message #7349 is a reply to message #7324] Thu, 05 June 2003 16:28 Go to previous message
Messages: 324
Registered: January 2003
Senior Member
it could be the thoma. why not try it out with other fonts like courier or times new roman
Previous Topic: How to convert Japanese Database/Form stack to English language
Next Topic: Japanese Oracle upgrade from 7 to 9i (merged)
Goto Forum:

Current Time: Sun Mar 03 19:27:37 CST 2024